Using Gummi Features

The Gummi user guide is currently a work in progress.

Getting Started

Continuous Preview Mode

smaller replacement

One of the main benefits of using Gummi is that changes you make to the document are almost immediately visible in the preview screen, letting you quickly get feedback on how your LaTeX formatting changes are affecting the document.

Syntax Highlighting

As you type latex commands these will be highlighted seperate to the rest of your text so that you can quickly find latex tags within your document.

Editor Themes

If you don’t like the default editor color scheme then you can choose alternatives via Edit → Preferences → Font & Colors, for example the Cobalt theme will give you a dark editor background with light writing as opposed to the default.

Command Completion

To save you time editing common blocks of LaTeX can have shortcut keys or command text assigned to them. Some common examples come pre configured with the program.

If you go to Edit → Preferences → Editor → Snippets , you’ll find that you can see and assign shortcuts to certain blocks of LaTeX you might commonly use.

For example, the img block is triggered by typing \img followed by hitting the Tab key, resulting in a code block for an image being pasted into the document.

If a snippet shows $1,$2 fields, these are where the cursor will go when tab is successively hit for example

\usepackage{$1}$0

has a default snippet shortcut of

upkg

so in the edit pane typing

upkg[TAB]lorem[TAB]ipsum

would result in the following text

\usepackage{lorem}ipsum

Via the Snippets box it’s also possible to assign key shortcuts, for example you might decide that pressing shift+i together will trigger the image codeblock .

Spell Checking

Spell checking is off by default but is enabled via the menu option
Document → Enable Spell Checking

Be sure that you’ve also selected a language in Edit → Preferences → Miscellaneous and that you have gtkspell installed

Spell checking currently highlights LaTeX commands but this is expected to change in the future (#142)

Wizards

If you need to make a section of code for a image, complicated table, matrix or bibliography file, look to the bottom of the preview pane.

Selecting the options you want and hitting enter injects the latex required into the editor pane at the cursors position. It may save you a lot of time.

Templates

Templates are fairly simple. You can save a document as a template, for instance you may create the rough outline of a report document and then load it each time you wish to write a report in order to have most of the document structure already created.

Have you got the latest stable release?

You can use the command line, for example:

 $ gummi --version
 Gummi 0.6.5
 $ gummi -v
 Gummi 0.6.5

Or you can use the Graphical user interface:

Go to Help → Check Updates

This will tell you if there’s a newer version of Gummi available

Projects

The current (0.6.x) implementation offers some support for grouping documents together.

Creating a project creates a plain-text file with compilation settings in it and the location of the files that are added to this project.

When a project is loaded, the file is read in and the lines containing a filepath are all loaded into Gummi.

Creating a project

The prerequisites are that your document must compile and be open in a document tab, this becomes the "root" file.

  1. Open your first file and save it
  2. In the menu bar select 'Project’ and then 'New’
  3. In the dialogue that comes up, choose a folder for your project and click save

In the right hand pane you now have an extra tab called 'Project’ which lists all the files in your project

Adding and removing files to a project

To add more files use the "add" button in the lower right hand side of the projects pane

Icons

The project overview tab uses two different icons to signify some status for the document. A "home" icon means that document is the root file of the project.

(An "error" icon means that the file is in the project, but we couldn’t load it. Most likely because it is either deleted, moved or damaged.)

Bibtex Integration

Synctex Integration

MakeIndex

preferences.png (75.8 KB) Guy Edwards, 22 March 2012 18:14

update.png (29.9 KB) Guy Edwards, 22 March 2012 18:34

lorem-ipsum.png - smaller replacement (118 KB) Guy Edwards, 13 April 2012 18:11